Discussion in 'USB - Seriell Wandler' started by ro-alarm, Oct 22, 2012.

  1. ro-alarm

    ro-alarm New Member

    Hallo Fangemeinde
    Habe ein Problem mit der Darstellung am PC. (keine Aufzeichnung)

    Erst mal meine Gerätekonfig.
    Notebook Intel Celeron 2,1 Ghz, 2GB RAM
    XCharge 220EQ mit Original Interface-Kabel von RC-Toy

    LogView installiert, Ver 2.7.4.485, erfolgreich abgeschlossen

    Treiber als ZIP Datei downgeloaded (Ver 5.2.2.0) entzipt und installiert
    installierter Treiber: SilikonLabs (CP210x USB to UART Bridge) an COM5 das "x" steht bei mir für "2", was ich auf dem Chip der Interface-Platine abgelesen habe
    Im Geräte Manager nachgeschaut, da steht folgende Meldung: "Das Gerät funktioniert einwandfrei"
    Unter Anschlüsse (COM & LPT) ist der Treiber gelistet als: SilikonLabs CP210x USB to UART Bridge (COM5)
    unter Treiber-Details habe ich noch herausgelesen: Ort: Port_#0001.Hub_#0006 , was auch immer das bedeutet..........
    Interface zusammengesteckt, Minus = schwarzer Draht an Interface-Platine und Minus am Lader = links am Netzstecker

    Interface am Notebook gestöpselt, LED rot leuchtet auf Interface-Platine
    LogView gestartet, Gerät und Port ausgewählt und Aufzeichnung gestartet. (nachdem ich einen Akku zur Ladung angeschlossen hatte) und, und, und???? na nix, keine Übertragung, kein Zucker auf dem Bildschirm zu sehen.

    Was habe ich falsch gemacht? Wer weiß Rat? Bin völlig ratlos:( und für jeden Beitrag und Hilfe dankbar.

    Kann übrigens jemand Angaben über einen Kurvenverlauf mittels Oszilloskop am Laderausgang machen? Vielleicht kommt am Ausgang des Laders ja schon kein Signal zustande.

    Gruß Bernd
  2. ro-alarm

    ro-alarm New Member

    Habe heute kurzfristig eine eigene Lösung gefunden.
    Der Fehler lag in einer falschen Treiberversion. Habe jetzt von SiLab die Treiberversion 6.5.3.0 installiert (Nachdem ich die alte Version ausgesondert habe) und schon hat alles reibungslos funktioniert.
    Gruß Bernd
  3. Holger

    Holger LogView Team

    Hallo Bernd,

    vielen Dank für die Meldung, dass Du das Problem schon gelöst hast!

    Die Rx-/Tx-Signale einer echten seriellen Schnittstelle kann man sich sehr gut am Oszi ansehen. Aus der Impulslänge kann man die Baudrate errechnen und mit etwas Erfahrung auch Details wie Dateninhalt und Formateinstellungen herauslesen.
    Auf einigen Oszis kann man sich auch den Dateninhalt der seriellen Übertragung direkt anzeigen lassen.

    Gruß, Holger
  4. ro-alarm

    ro-alarm New Member

    Hallo Holger, danke für für Deine Unterstützung.
    Wäre da nur noch zu klären, ob die ganzen Laderschnittstellen dann "echte" serielle Schnittstellen sind. Das Tx Signal des Laders kann ich ja jetzt empfangen (sehe ich, dem Himmel sei Dank, jetzt auf dem PC). Habe aber immer noch keine Erkenntnis, wie ich dieses Signal (wenn ich mal keinen PC mit installiertem LogView und Schnittstellenkabel zur Hand habe) vorab mit dem Oszi definieren kann. Ist zwar nur ein 2 poliger Port, kann man also nichts falsch anschliessen, aber wie groß sind die Signale? Welche Werte sind zu erwarten, also was muß ich am Oszi einstellen, um ein aussagekräftiges Signal am Ausgang der verschiedenen Lader erkennen zu können? (Spg/Div, Zeit, Trig)
    Vielleicht gibt es aber auch noch eine einfachere Möglichkeit, um feststellen zu können, ob die Laderschnittstelle überhaupt sendet.
    Kann mir jemand weiterhelfen?

    Gruß Bernd

Share This Page