Discussion in 'Aufbau' started by wkrug, Apr 23, 2006.

  1. wkrug

    wkrug New Member

    Hallo Leuz,

    ich hab meine Platinen bis auf ein paar wenige Bauteile bereits bestückt.
    Ein Problem tauchte bei mir bei der Analogplatine auf.

    Text Baubeschreibung:
    Buchsenleisten (2x20 abgewinkelt) von unten in die inneren Lochreihen stecken und von oben verlöten, vorher die nicht benötigten Kontakte abschneiden/entfernen.

    gewinkelte Buchsenleisten Rastermaß 1,27mm konnte ich nicht auftreiben.
    Ich hatte auch nur einreihige Buchsenleisten eingekauft.
    Die Pins weiter auf der Platineninnenseite also oben hätten alle verlängert werden müssen. Das war mir zu instabil.

    Meine Lösung war eine Stiftleiste auf die Oberseite ganz aussen zu bestücken und auch von oben zu löten.
    Die nach unten Vorstehenden Beinchen hab ich so kurz wie möglich abgeschnitten (Printplattenseitenschneider).
    Danach hab ich die Unterseite mit den Buchsenleisten bestückt und von oben verlötet.
    Ich hoffe ich hab mir da nicht wichtige Optionen verbaut.
    Thomas und Dominik werdens hoffentlich wissen.

    Attached Files:

  2. Dominik

    Dominik Administrator Staff Member

    Moin !

    Also wir hatten uns überlegt, das man dort auch Servobuchsen mit Kabel anlöten kann. Dort kommen dann (je nach Bedarf) die Sensoren ran.

    Ansonsten siehst ja schon subba aus.
    Und scheinbar muss ich mich jetzt richtig ins Zeug legen mit dem Konfig Tool ... Ich dacht ich hätte da noch 1-2 Wochen, aber dein Logger ist ja bald fertig ...
  3. Thomas

    Thomas New Member

    Hallo Willi,

    sieht ja schon gut aus.
    Das mit den gewinkelten Bu-Leisten ist ein Problem, da es bei Conrad & Reichelt keine gibt. Bei Bürklin könnte man welche bestellen.
    Deine Lösung finde ich auch nicht schlecht. Ansonsten wie Dominik geschrieben hat - Kabel anlöten.

    Wie weit ist Deine Controller-Platine?

    Gruss
    Thomas
  4. wkrug

    wkrug New Member

    Die Controller Platine ist fertig bis auf den 3kOhm 0805 Widerstand (krieg ich vermulich diese Woche noch).
    Und alle Stiftleisten fehlen noch weil Reichelt die zur Zeit nicht auf Lager hat.
    Das Displayboard ist bis aufs Einlöten vom Display auch fertig, ebenso das SD Speicherboard.
    Der Schaltplan für den MAX 232 Adapter hab ich auch noch nicht gefunden, macht aber nichts solange ich nicht alle anderen Bauteile hab.
    Die Stiftleisten hab ich kurzerhand bei Conrad bestellt, sollten also auch diese Woche noch kommen.

    @Thomas:
    Soll ich dir für deine Bauanleitung Fotos schicken wenn ich alle Platinen voll bestückt hab ?
  5. wkrug

    wkrug New Member

    Die Controller Platine ist fertig bis auf den 3kOhm 0805 Widerstand (krieg ich vermulich diese Woche noch).
    Und alle Stiftleisten fehlen noch weil Reichelt die zur Zeit nicht auf Lager hat.
    Das Displayboard ist bis aufs Einlöten vom Display auch fertig, ebenso das SD Speicherboard.
    Der Schaltplan für den MAX 232 Adapter hab ich auch noch nicht gefunden, macht aber nichts solange ich nicht alle anderen Bauteile hab.
    Die Stiftleisten hab ich kurzerhand bei Conrad bestellt, sollten also auch diese Woche noch kommen.

    @Thomas:
    Soll ich dir für deine Bauanleitung Fotos schicken wenn ich alle Platinen voll bestückt hab ?
  6. Dominik

    Dominik Administrator Staff Member

    Moin !

    Is bestimmt auch nich verkehrt hier welche zu posten. Denn das interessiert bestimmt viele wie das Teil dann so fertig ausschaut. Gibt zwar schn ein paar von Thomas hier, aber schaden kanns nich :)
  7. Thomas

    Thomas New Member

    Ist der Controller auch schon drin? Dann würde ich nicht warten sondern anstelle des 3k - Widerstands einen mit 4.7k und einen mit 10k parallel auflöten...

    Hier ist er.
    Du kannst aber fürs erste jeden Programmieradapter nehmen. Die Anschlüsse für die Programmierung liegen auf der 6-poligen Buchse zwischen den Tastern. Wenn Du auf die Oberseite auf die Platine schaust von links nach rechts:
    +5V
    SCK
    MISO
    GND
    MOSI
    Reset (ist auf der Platine mit R gekennzeichnet)


    Bilder sind immer willkommen.

    Gruss
    Thomas
  8. wkrug

    wkrug New Member

    @Thomas:

    ist zwar gut gemeint aber ich hab noch keine Stiftleisten (Programmieradapter) hier.
    Also muss ich wohl oder übel auf die Conrad Lieferung warten.

    Ich werd dann derweil noch ein 3410 Display für ein anderes Projekt herrichten.
  9. wkrug

    wkrug New Member

    Here they are:

    Bilder von den fast fertig bestückten MidiLogger Platinen.
    Es fehlen noch die Stiftleisten und der 3K Widerstand auf der Prozessorplatine.

    Attached Files:

  10. Dominik

    Dominik Administrator Staff Member

    Great work man !!!

    Dann muss ich dir bald ne Vorabversion der Konfigsoftware schicken, wie?!
  11. wkrug

    wkrug New Member

    Logger Hardware Fertig

    Hallo Leutz,

    hab soeben noch den fehlenden 3kOhm Widerstand bekommen und gleich eingebaut.
    Der Controller wäre somit zum Flashen bereit. :rocks:
    Den Programmieradapter hab ich noch nicht aufgebaut, da möcht ich aber auf eine gescheite Platine warten.

    Wie weit seid ihr (Thomas und Dominik) mit der Software ?

    Nicht das ich euch hetzen will, ich wart natürlich solange bis ihr fertig seid.

    Als Programmiertool verwende ich zur Zeit PonyProg, ein Programmieradapter ist auch vorhanden.

    Mir würd zur Zeit das *.hex (+ *.eep) File sowie die Fusebit Einstellungen reichen.
    Thomas meinte die Konfiguration wäre mit seiner Hilfe auch so zu machen.
  12. wkrug

    wkrug New Member

    Der Controller ist geflashed - ging auf anhieb.
    Dann hatte ich noch die Verbindungen vom Controllerboard zum Speicherboard verdreht.
    Die serielle Ausgabe klappt.
    Das beschreiben der SD Karte auch.
    Was bis jetzt noch nicht funktioniert ist das Display.
    Ich hab schon 3 verschiedene 3410 ausprobiert - funktioniert nicht.
    Ein 3510 (ohne "i") hab ich auch schon probiert - geht nicht.
    Die Leitungen vom Controller zum Displayboard hab ich gleichstrommässig und auch mit dem OSZI gechecked - da scheint alles in Ordnung zu sein.
    Diese Woche werd ich noch ein 3510i (hoffentlich mit Metallanschlußleiste) kriegen. Wenn das wieder nicht geht tausch ich den ATMEGA 128 aus.

    Jetzt meine Frage:
    Soll ich, wenn nötig, einen ATMEGA 128-16 TQ oder doch einen ATMEGA 128L8 TQ einbauen ?
    Bis jetzt hatte ich einen 128-16 drin.
    Eigentlich sollten ja beide gehen.

    P.S.
    @Thomas - Danke Dir noch mal für deine Hilfe beim Fehler suchen.
  13. Thomas

    Thomas New Member

    Hallo Willi,

    wenn Du den Mega128 tauschen willst solltest Du die L-Version nehmen. Der andere ist nur bis 4.5V spezifiziert, ich glaube aber nicht das es daran liegt.

    Gruss
    Thomas
  14. wkrug

    wkrug New Member

    Hallo Leute,

    es läuft.
    Nach dem Einbau des Nolia 3510i Displays hab ich nun endlich eine Anzeige.
    Anscheinend gibt es auch beim 3410 verschiedene Controller.
    Meine waren immer vom selben Anbieter.

    Das 3510 ist vom E-Bay Anbieter "handy-teile-store".
    Ich hab aber extra geschrieben das ich ein Display mit Kontaktfedern und nicht mit Kontaktgummis will.
  15. mitfried

    mitfried Member

    hier ist mal ein Foto meiner Version mit SD Card Adapter
    die gewinkelten Buchsenleisten hab ich auch noch nicht drauf, muss mir noch überlegen ob ich überhaupt welche draufmach oder vielleicht wie Dominik vorschlug die Sensoren mit einem Kabelstrang und Servobuchsen anschließen werde..

    hoffe dass soweit alles richtig ist,

    hab auch ein Foto vom (provisorisch) zusammengesteckten Logger gemacht, man erkennt, ich (man) sollte die Stiftleiste vom Analogboard zum ControllerBoard etwas verkürzt einlöten, so wie ich es eingelötet habe (wies aus der Tüte kommt) verschenke ich ca. 3-4mm in der Dicke des Loggers

    sonst gings eigentlich problemlos laut anleitung
    PS: R303 hab ich nicht eingelötet, da er nicht erwähnt wurde. stimmt das?

    Attached Files:

  16. Thomas

    Thomas New Member

    Das stimmt.
    R302-R304 kodieren den Displaytyp, daher ist R303 bisher noch nicht nötig.

    Sieht ansonsten sauber gebaut aus. Die Stiftleisten kannst Du doch etwas kürzen, müssen nur anschliessend gut entgratet werden. Ansonsten kann man die Stiftleisten auch mit den langen Enden durch die Platine stecken und die kurzen Enden für die Kontakte benutzen. Oder vor dem einlöten die Kontaktstifte in dem Plastikhalter passend zurechtschieben.

    Gruss
    Thomas
  17. mitfried

    mitfried Member

  18. wkrug

    wkrug New Member

    @ mitfried

    Ich hatte die Stiftleisten von Conrad, die passten von der länge hes ganz genau, ohne kürzen oder rausschieben.
  19. mitfried

    mitfried Member

    jetzt wird der eine oder andere vielleicht lächeln, aber ich hab anscheinend obwohl ichs damals sicher 3x gecheckt hab (anscheinend genau falsch rum) den atmega genau falschrum eingebaut.. so ziemlich der besch***** fehler den man machen kann.. was gibts für tips um ihn wieder auszubaun? ich hab nur "normale" Arbeitsmittel (7,5-15-25W Lötkolben, Entlötlieze)
    Hat den Fehler schon mal wer gemacht bei so einem IC?
    wie stehen sie Chancen, dass er ca. 2x20sek an 5V überlebt hat (geregelt) ?
    er wurde lauwarm :{
    schande auf mein haupt und naja, mal schaun

    NACHTRAG: er hats problemlos überlebt ;-)
  20. Dominik

    Dominik Administrator Staff Member

    Moin !

    Also wenn er schon warm geworden ist ... Das heisst nix Gutes ... Ich könnte mir gut vorstellen das er übern Jordan is ...

    Auslöten: Hmm, da kann Peter vielleicht was zu sagen !?

Share This Page