Discussion in 'International Area' started by asomaro, Mar 8, 2011.

  1. asomaro

    asomaro New Member

    I've loaded logview successfully on my windows 7 and Vista machines. The logview appears to be connecting to the Powerlog 6s logger, but I cannot see any graphic representation. The "connection" light is green and when either uploading a log or if I connect for a live view, the "rx" light indicates that data is flowing but I cannot see any graphics? :confused:

    Also looked at the serial logging and debug logging and they both indicate that something is happening every 2 seconds.

    Have I missed something, surely I should be able to see some graphs of the feed? Any help would be much appreciated. ;)

  2. Biggy Boy

    Biggy Boy New Member

    I have the exact same problem as you.
    I'm running Win 7 and the latest ver. of Viewlog software. My Rx light works but no data is on the computer screen.
    Have you got it figured out let????? I wonder if it is a USB driver problem

    When I tried to use the upgrade program for the Powerlog 6s it showed "no device detected" warning??

    Did you get yours from Hobby King?

  3. Dominik

    Dominik Administrator Staff Member

  4. asomaro

    asomaro New Member

  5. Biggy Boy

    Biggy Boy New Member

    I actualy found the solution on RC groups, that pointed me to the same link you just posted.

    Sorry for not using the search function properly.

  6. Biggy Boy

    Biggy Boy New Member

    Ok I have live data working and it shows up in a box at the right of the screen.
    Now how do I get the logger data to show up?
    I selected the file and selected file transfer and I saw the RX light go green, but no data on the screen?
    The data was saved on the powerlog 6s first by holding down the bottom button until it said log started I ran a motor that drew 28 amps for 10 seconds then I held the button again until it said log stoped. then I tried to transfer the data to your software!?!?!?

  7. asomaro

    asomaro New Member

    I too now have the live data feed working. I tried changing the .ini file on my PC but found that it worked only when I used the programme itself to edit the .ini file. (tools menu, edit ini file) then I changed the cluster size to 65. Cool it works.

    I'm now trying to figure out (like Glen) how to see the transferred logfile. I've logged data on the logger itself, then hit the transfer button, it registers on the logview that data is transmitting, but I can't find it. I checked the location of where the files are supposed to go - but they are not there, hmmmm more work required to find out where the files are going....
  8. Biggy Boy

    Biggy Boy New Member

    Hello Simon
    I've been at this for hour and hour on end :-( I can now see logged data but it is all messed up. graph.vsd.jpg

    Here is a graph can't make heads or tails of it? the time stamp at the bototm is all over the place?

    I too changed the cout to be 65 instead of 64, maybe there is more to this puzzle?

  9. asomaro

    asomaro New Member

    Hi Glen,

    My graphs appear to be OK. I did the following to ensure that the clustersize thing was set everywhere:

    a) Tools/edit ini - adjusted the ini to show "65" on both the serial and usb bits (even though it says the serial is unused)
    b) Tools/open devices folder - found the junsi powerlog ini file and changed that as well to 65 for both USB and serial

    since then I've been messing about with the graphs, however, I still can't find the "transferred" logs that I've tried to upload from the device to my pc - they do apppear to be going somewhere, have you had any luck?
  10. Biggy Boy

    Biggy Boy New Member

    Im still having problems with my graph looking good.
    I was able to change some of the text to english by editing that INI file.
    Did you notice that if you reopen the INI file in the tools edit INI in the software the 64 you changed to 65 for the serial, goes back to the value of 64!!! At leased it did on mine repeatedly.

    There is a guy in RCgroups that is writing an easy to use program to view powerlog 6s files. i'll post the link to you if you like.

    Can you look at your table view and look at the time stamp in the first colume and see if the numbers look right.
    Mine are all messed up. look I copied and pasted what mine looks like.

    10h 14m 24s,
    20h 28m 48s,
    6h 43m 12s,
    16h 57m 36s,
    3h 12m 00s,
    13h 26m 24s,
    23h 40m 48s,
    9h 55m 12s,
    20h 09m 36s,
    6h 24m 00s,
    16h 38m 24s,
    2h 52m 48s,
    -13h 21m 56s,
    13h 07m 12s,
    -13h 21m 56s,
    23h 21m 36s,
    9h 36m 00s,
    19h 50m 24s,
    6h 04m 48s,
    16h 19m 12s,
    2h 33m 36s,
    12h 48m 00s,
    23h 02m 24s,
    9h 16m 48s,
    19h 31m 12s ,

    Thanks Simon
  11. Dominik

    Dominik Administrator Staff Member

    Hi !

    That´s the place where you should change the number to 65. And you can change the names there, too.

    Don´t use the internal INI Editor. It´s mainly for testing purpose.

    Let me check my Powerlog this evening. I will look for any errors in the data conversation.
    And I will post an more detailed step by step guide on how to transfer the stored logs.

    Sorry for the trouble so far.
  12. asomaro

    asomaro New Member

    Great - thanks for your help, its a great bit of software, I just want to get the best out of it!


  13. Biggy Boy

    Biggy Boy New Member

    OK my Graphs look better now Simon.
    The time stamping is now correct.
    And the data is no longer garbled.

    test #4.jpg

  14. asomaro

    asomaro New Member

    Just need to sort out the data transfer now - mine is now mounted on my helicopter ready for a test flight - all I need to work out is how to upload the data, hopefully Dominik will come up with the solution.
  15. Biggy Boy

    Biggy Boy New Member

    Any progress on getting the software to work properly?

  16. Dominik

    Dominik Administrator Staff Member

    Hi @all,

    Sorry for the delay but I´m a little bit busy with LogView V3 at the moment :)

    Anyway ... Here are the steps to get the logged data from the PowerLog 6s:

    • Start LogView :)
    • Select the PowerLog 6s und select the HID port.
      Ensure that the PowerLog is connected and that windows has detect a HID device!
    • Now open the port in LogView:
      Menu -> Device -> "Open port / recording"
    • Now go the PowerLog and hold Menu for ~3Sec.
    • In the menu select Log files and press Menu
    • Select the Logfile you want to transfer to LogView
      Note : If you can´t see a log file here you have to create one. Take a look into the PowerLog manual how to create and use Logfiles!
    • Select "File transmit" and press Menu again.
    • Now you can see a transfering screen with a fast running counter.
    • Now you should have data in LogView :)
    I tested this with PowerLog version 1.04. I´m actually not sure if there is a newer version. But the process should always be the same.

    Hope this helps.

    Attached you can see my recording ...

    Attached Files:

  17. asomaro

    asomaro New Member

    All working fine now - thanks for your help.

Share This Page