Discussion in 'GPS' started by emu, Apr 7, 2013.

  1. emu

    emu New Member

    Hallihallo,

    wollte gerade die NMEA-Daten meines GPS-Empfängers live in Logview angucken. Leider tut Logview nichts.

    Habe folgendes eingestellt:
    - Baudrate der Schnittstelle in Windows angepasst
    - Baudrate der Schnittstelle in Logview in der Datei nmea0183.ini angepasst (warum muss man den Umweg über die Datei gehen? besser fände ich eine Konfigurationsmöglichkeit direkt in Logview)
    - NMEA bei Geräte in Logview angewählt
    - die serielle Schnittstelle in logview ausgewählt
    - die Aufzeichnung gestartet

    Ergebnis:
    unter serial logging wird mir so etwas angezeigt:
    19:02:20,632 [A] 4–¶æ¼´<VT><SOH>²¼,ë<DC4>Ám²”m²´)<SUB>4´<VT>4h”¼4hŽ´µ²”¶<EM>ý
    19:02:21,207 [A] 4–¶æ¼´‹<SOH>²¼´<Esc>§¦m²”mr´)h4l<VT>th<DC4>¼4
    19:02:21,671 [A] h<DC4>´µ²”¶<EM>ý
    19:02:21,804 [A] 4–¶î¼´<VT><SOH>²ü´<Esc>)¦m²”m²´)<CAN>Ì´<VT>4h<DC4>¼lh”´µ²”.4ÿ
    19:02:22,350 [A] 4–¶æ¼dƒ2¼4Û<DC4>Km²”m²´)h4´<VT>4h<DC4>¼4h<DC4>´u*”&4ÿ
    19:02:22,963 [A] –Mæ¼´<VT>²¼´<Esc>)¦<CR>²”m²´)h4´<VT>4h<DC4>¼dhŽ´µ²”¶<EM>ý
    19:02:23,570 [A] 4–¶,,´<VT><SOH>²¼´<Esc>/xm²”m²´)h4´<VT>4hŒ¼4h<DC4>¤

    im externen Terminal erhalte ich jedoch saubere Daten in der Form (nachdem ich den Port in Logview geschlossen und im externen Terminal geöffnet habe):
    $GPGGA,001733.047,,,,,0,00,,,M,0.0,M,,0000*53<\r><\n>
    $GPRMC,001733.047,V,,,,,,,160406,1,,N*7C<\r><\n>
    $GPGGA,001734.060,,,,,0,00,,,M,0.0,M,,0000*51<\r><\n>
    $GPRMC,001734.060,V,,,,,,,160406,1,,N*7E<\r><\n>


    Somit kann ich alle anderen Fehlerquellen ausschließen.
    Ich schätze, die Baudrate wird von Logview irgendwie vermurkst. Was kann ich tun?

    PS:
    In nmea0183.ini ist unter [serielle Schnittstelle] die rede von einer settings.ini, die Datei kann ich aber nirgends finden.
  2. emu

    emu New Member

    Hm, ist das etwa ein Problem, für welches keiner nen Rat hat? Wie bringt ihr denn Eure NMEA-Daten zur Anzeige?
  3. emu

    emu New Member

    Danke. Weder eine direkte Mail an Dominik wird beantwortet, noch findet man hier im Forum Antworten. Ich schau mich dann mal nach Alternativen um ;)
  4. Holger

    Holger LogView Team

    Hallo emu,

    ja, Dominik wäre eigentlich der Experte für das Thema GPS.
    Ich kann erstmal nur so viel sagen, dass die Baudrate offensichtlich nicht passt.
    Du musst evtl. aufpassen, in welchem Ordner Du die ini-Datei anpasst. Am besten immer den Weg übers Menü in LV gehen: Tools/öffne 'Geräte', nur die dort zu findende Datei NMEA 0813.ini wird bei einem installierten LV berücksichtigt!

    Dass es dazu noch keine Konfigurationsmöglichkeit in LV gibt, hat lediglich den Grund der bisher nicht so hohen Priorität. Du kannst aber einfach eine Kopie der vorhanden NMEA ini Datei mit einem geändertem Setting und einem angepassten Namen in dem gleichen Ordner ablegen.
    Nach solchen Änderungen immer LV neu starten, damit die Dateien alle brav neu eingelesen werden! Dann das 'neue' Gerät auswählen und verwenden!

    Gruß, Holger

Share This Page