Discussion in 'International Area' started by takilara, Mar 4, 2009.

  1. takilara

    takilara New Member

    Hi. I have been using LogView to monitor my Graupner Ultramat charger, and I like the program very much.
    However I no longer have a windows computer available.

    I searched these forums abit, and found some german threads describing running LogView using Wine.

    I've gotten LogView running, and i have gotten the usb->Serial drivers to work, However, when i try to start logging in LogView, i get a message that it cannot open the COM port...

    Is there any walkthrough/manual that describes how to get LogView working under wine?

    Other info:
    Ubuntu 8.10
    usb->serial shows up as /dev/ttyUSB0
    all users have read/execute access to /dev/ttyUSB0
    "cat /dev/ttyUSB0" gives me output from the charger perfectly
    "stty -F /dev/ttyUSB0" gives:
    speed 9600 baud; line = 0;
    -brkint -imaxbel

    I have made symlinks to ~/.wine/com1 and ~/.wine/Com1 from /dev/ttyUSB0
    I suspect there is something else i need todo to "connect" the serial port to wine. Any suggestions?

  2. Winfried

    Winfried New Member


    the problem might be, USB devices are created dynamically. You can try to write an udev rule to create an link each time /dev/USBx is created.

    I had the same problem and decided to write my own LogView, its called OpenSerialDataExplorer. But this will not solve your problem since I have only implemented devices I own.

    have fun

  3. takilara

    takilara New Member

    Tried to recreate the link with no luck.

    However got it to work by doing the following (not sure wich thing fixed it)
    - chmod a+rwx to the LogView folder and its contents
    - changed from a+rx to a+rwx on /dev/ttyUSB0

    I do suspect however, that I will have the same problem as you, if i disconnect the device, and reconnect it. That I will have to recreate the link and resets its permissions, so very nice tip regarding the udev


Share This Page