Discussion in 'International Area' started by Dolphyn, Feb 21, 2010.

  1. Dolphyn

    Dolphyn New Member


    I use the "Junsi CellLog 8S" device. Is there a recommended way to use LogView with variable time step? It defaults to 2 seconds, but I often use CellLog with a different time step.

    I can alter TimeStep_ms in the Geraete file, but I don't want to use the same time step for every data set.

    I tried using extra files in the Geraete directory with different values of TimeStep_ms, but it didn't work. (Data import always failed when I tried to use my alternative settings.)

    Any suggestions? Is there any way to alter the value of TimeStep_ms in an existing .lov file? Thanks!
  2. Dominik

    Dominik Administrator Staff Member

    Hi !

    I´m sorry, but normally you don´t have to configure anything.
    The timestep should read from the CellLog !

    Did you cibnfigure the timestep within the celllog correctly ?
  3. Dolphyn

    Dolphyn New Member

    Hi Dominik,

    I tried to reproduce the problem I had, and now LogView is detecting the timestep correctly. So, I'm sorry to waste your time!

    I'll let you know if I figure out what was happening before. I think I updated firmware since then, so maybe it's a problem with the old CellLog firmware.

    Thank you for your response!
  4. Dolphyn

    Dolphyn New Member

    Problems if TimeStep is > 30 seconds

    Sorry, it's me again. :p

    It seems to work okay for time steps up to 30 seconds or so, but strange things happen above that, including negative numbers which cause the graph to display backwards!

    For example:

    30-second interval: 0, 30s, 1m 00s, 1m 30s, 1m 00s (as expected)

    34-second interval: 0, -31s, -1m 03s, -1m 34s, -2m 06s

    40-second interval: 0, -25s, -51s, -1m 16s, -1m 42s, -2m 07s

    50-second interval: 0, -15s, -31s, -46s, -1m 02s, -1m 17s

    60-second interval: 0, -5s, -11s, -16s, -22s, -27s, -33s

    90-second interval: 0, 26s, 52s, 1m 18s, 1m 44s, 2m 10s

    120-second interval: 0, 9s, -19s, -28s
    Any ideas? Thanks!
  5. Dolphyn

    Dolphyn New Member

    I tried upgrading to LogView 2.6, and it has different behavior: Instead of showing negative numbers, it shows an error message.

    So, I cannot successfully upload data with 60-second TimeStep, and cannot view my existing file (with the erroneous negative numbers).

    I'll send an error report with a sample file. Thanks!
  6. Dominik

    Dominik Administrator Staff Member

    Hi !

    Ok, I did some investigation about this problem.
    And first I can´t figure out the bug. But after a while I noticed that the timestep is stored into a SmallInt variable. This is from ~ -32000 to 32000.
    And the Timestep comes in milliseconds. So if you got 60 seconds Timediff from the device you will get an internal value of 60000. And that can´t be stored into a smallint :)
    The result for 60000 is -5435. well and that is the explaination for the negative times you got.

    This problem is fixed in the next 2.6.1 release which comes this weekend.
  7. Dolphyn

    Dolphyn New Member

    Hi Dominik, thanks for your work on this!

    Evidently there's another variable that is "wrapping around" because I'm still getting very strange results with the newest version.

    My CellLog had about one month of continuous data using 30-second interval, but either CellLog or LogView broke the data set into two pieces, and the second piece (containing about 5 days of data) is displayed very strangely. See attached screen shots.


    Attached Files:

  8. Dolphyn

    Dolphyn New Member

    I'm sorry to bring this up again, but I still get incorrect results when using larger TimeStep intervals with LogView 2.6.4 and CellLog firmware 2.0.6:

    50-second interval: 0, 50s, 1m 40s (as expected)

    60-second interval: 0, 1m 00s, 2m 00s (as expected)

    70-second interval: 0, 6s, 12s, 18s

    80-second interval: 0, 16s, 32s, 48s

    90-second interval: 0, 26s, 52s, 1m 18s, 1m 44s

    100-second interval: 0, 36s, 1m 12s, 1m 48s

    110-second interval: 0, 46s, 1m 32s, 2m 18s

    120-second interval: 0, 56s, 1m 52s, 2m 48s

    By the way, even with lower TimeStep values, I always get strange-looking labels on the X-axis, because I use CellLogs for weeks at a time and %hh wraps around at 24 hours. I suggest changing the default "Timeformat for X Axis" from R_%hh"h" %nn"m" %ss"s" to R_%d"d" %hh"h" %nn"m" %ss"s". (This shows the days only after 24 hours, as far as I can tell.)

  9. Dominik

    Dominik Administrator Staff Member

    Hi Dolphyn,

    well I just did some tests with my latest version of LogView. It works very well in all conditions.
    I´ve did some tests with 14 sec interval and 60sec. Works like a charme.

    I think there are two possibilities ...
    1) Your LogView is outdated and I have a newer version (with fixes included)
    2) We talk about different things.

    Do you have a problem because the x axis shows not exact the values you add to the chart?
    You should notice that the labels which are added to the X axis are calculated by the chart engine. The engine always trys to show the labels in a proper / good looking way.
    So in some case you will see exact the values which are added from the CellLog (like your 60 sec test). But in other situations the X labels are completely different compared to the values which are added. That´s normal.

    Accoring to my first possibility you can write my an email an I will send you the latest LV version.
    -> dominik ÄT logview DOTTER info
  10. Dolphyn

    Dolphyn New Member

    Hi Dominik,

    I think we're talking about different things. I had trouble with 60-sec intervals in the past, but you fixed that. I'm still having trouble with intervals over 64 sec, as in the examples I gave above.

    I looked at the "Zeit" column in Table view to see how LogView was handling the X-axis data. For example, using a 120-sec interval:
    CellLog-Example.jpg (click to enlarge)

    Of course this also affects the X-axis display of the graph (using R_%d"d" %hh"h" %nn"m" %ss"s"):
    CellLog-Example2.jpg (click to enlarge)

    But, it is even more confusing using the default timeformat (R_%hh"h" %nn"m" %ss"s"):
    CellLog-Example3.jpg (click to enlarge)

    I'll go ahead and send you an email message as you requested.
  11. Dominik

    Dominik Administrator Staff Member

    Hi Dolphyn,

    I´m really sorry ... Now I can reproduce your problem here.

    But I think this is a firmware problem of the CellLog and NOT a LogView problem.

    I did the following test:
    CellLog was set to 80 seconds (which is over 64 ;) ). I logged some minutes and transfered the data to the PC. I had 9 lines of data which should result in 8*80 Sec = 640Sec (line 1 is in LogView 0 sec !). But LogView shows me 2min08sec. :mad:

    So I started our Logging tool and got this line:
    This is the Timestep which comes directly from the device. And it shows me 16 seconds ... and NOT 80 seconds ...

    And this results in wrong X values :cool:

    If you take a closer look at the CellLog you will see that the config screen shows:

    So I wonder why we can configure values > 60.

    I will write to Junsi to clear this problem. But actually i have to say ... Time intervals > 60 are not useable with the CellLog.
  12. Dominik

    Dominik Administrator Staff Member

    NEWS 14.08.2010
    Junsi has confirmed this bug and works on a new Firmware!
  13. Dolphyn

    Dolphyn New Member

    Thanks Dominik, I appreciate it!

Share This Page